QuickBooks Desktop Sync - Unable to continue, the current company file is unexpected

Description:

When attempting to communicate with QuickBooks (e.g. when syncing), you may get the following error message:

A QuickBooks company data file is already open and is different then the one requested or a Begin End Session error

or 

Unable to continue, the current company file is unexpected


Cause:

The file path as opened by QuickBooks is different than the file path requested by Order Time.

E.g. The QuickBooks file open as \\Server\MyFile.QBW  and in the Order Time Sync Tool as Q:\MyFile.QBW


Resolution:

1. In QuickBooks go to the File menu, Open Previous Companies and make a note of the EXACT path shown at the top. This is how QuickBooks is currently accessing your QBW data file.
2. Have all users log out of QuickBooks and close it
3. Open the Order Time QuickBooks Desktop Sync Tool
4. Browse for the QBW using the exact path noted in step 1. Save and close.
5. Open QB back up and try to sync