B2B Portal: Can Not See Customer Addresses

Overview

When a B2B Contact checks out on the B2B Portal and they cannot see the list of Company/Customer addresses to select one as the shipping address.


Cause

It is important to remember in Order Time a Contact and a Customer are two different records. A Contact is a record attached to a Customer. 

If a B2B Contact has an address on its profile in Order Time, then the B2B Contact’s address will be the default address used as the shipping address when checking out on the B2B Portal. The B2B Contact will not see or be able to select One of the Customers' addresses to use for shipping.


Solution

To allow the B2B Contact to see and select from their related Company/Customer addresses you will need to delete B2B Contact’s address from Order Time. After the Contact’s address is deleted, the Contact should log out of the B2B portal and then log back in. The Contact should now be able to see the Company/Customer Addresses and select from them.