Overview:
If you receive a sync error that reads: The Given Object ID in the Field is Invalid Then this article is for you.
Cause:
Receiving that error is most likely the result of trying to delete or modify an item that can not be found by its ID in QuickBooks. The reason the item ID can not be found by QuickBooks is usually do to the item have been deleted from QuickBooks and then trying to sync the quantity of that same item from Order Time.