Overview:
You have received sync error - An attempt was made to delete an invoice with a date that is on or before the closing date of the company.
Issue:
This error message appears during the synchronization between Order Time Inventory and QuickBooks Online: “An attempt was made to delete an Invoice with a date that is on or before the closing date."
Cause:
This occurs when you try to delete a document from a closed period in QuickBooks.
Solution:
Just like in OverTime, you can put a closing date on a time period in QuickBooks.
What that will do is it helps prevent any editing (or in this case deleting) of transactions before that date.
To delete/edit, they need to have the QB admin login and remove the closing date. Then they can make the changes, and then they can put back the closing date.